The TrueSight Capacity Optimization (TSCO) vCenter Extractor Service is failing with error, "BCO_ETL_FAIL103: Cannot connect to vCenter. - Includes Video
The TrueSight Capacity Optimization (TSCO) vCenter Extractor Service is failing with error, "BCO_ETL_FAIL103: Cannot connect to vCenter. - Includes Video
The CO vCenter Extractor Service is failing with error, "BCO_ETL_FAIL103: Cannot connect to vCenter. Exception: java.rmi.RemoteException: ... Connection refused" or "java.net.ConnectException: Connection timed out"
TrueSight Capacity Optimization
Capacity Optimization
TrueSight Capacity Optimization 20.02, 11.x, 10.x
Symptoms
The error in the TrueSight Capacity Optimization (CO) vCenter Extractor Service logs are:
BCO_ETL_FAIL103: Cannot connect to vCenter: Contacting vCenter URL: https://hostname/sdk with user: [user] BCO_ETL_FAIL103: java.lang.Exception: Cannot connect to vCenter. Exception: java.rmi.RemoteException: VI SDK invoke exception: java.net.ConnectException: Connection refused
Or
BCO_ETL_ERR011: ETL abnormally terminated: java.net.ConnectException: Connection timed out
You can watch this video to see how to troubleshoot and solve this issue:
Cause
This error generally means either:
The specified hostname of the vCenter is incorrect
The Specified port for the vCenter web API is incorrect
There is a firewall blocking the connection between the CO ETL Engine and the vCenter
Solution
One good way to test this behavior outside of the CO product is to run the following command from the command line of the ETL Engine Server: wget https://hostname:port/sdk
The expectation is that the wget will also fail with the same connection refused or connected timed out message. Once the error has been reproduced outside of the CO product it can be referred to the vCenter system administration team for further analysis.
Additional Information
Another good test is to attempt to connect to the following URL via a web browser: https://hostname:port/mob
That will prompt for a username and password. If successfully authenticated it will present a page of XML. That particular URL isn't used by the CO vCenter Extractor Service but, in general, if it is possible to authenticate with vCenter via that URL that validates that both the URL is correct for access to that vCenter and that the specified user account at least has initial login access (although that doesn't test access to collect performance data from the environment).
Q: What network port is required for the TSCO ETL Engine to be able to access the vCenter?
The vCenter Extractor Service and VMware History Extractor communicate with the vCenter using the vSphere Web API which is listening on port 443 on the vCenter (the standard https port). In relation to configuring a network firewall, the ETL Engine initiates a TCP network connection to the vCenter on port 443 (https).